Clipper On Line • Ver Tópico - NFS-e Erro: "Falha ao Recepcionar Lote de RPS"

NFS-e Erro: "Falha ao Recepcionar Lote de RPS"

Discussão sobre a linguagem CA-Clipper.

Moderador: Moderadores

 

NFS-e Erro: "Falha ao Recepcionar Lote de RPS"

Mensagempor Tadeu » 22 Mar 2012 21:37

Olá Pessoal, boa noite

Estou enfrentando um problema após gerar o arquivo XML e enviá-lo para validação no site da Prefeitura, para alguns arquivos estou recebendo a mensagem : " Falha ao Recepcionar Lote de RPS", alguém já passou por essa mensagem de erro ? Isso não ocorre sempre, esse mês de março já tive 3 arquivos XML que deram essa mensagem os demais foram validados sem nenhum problema.

Se alguém já passou por esse erro e tiver alguma dica, fico muito grato.

Um grande abraço a todos..

Obrigado,

Tadeu
Tadeu
Usuário Nível 1

Usuário Nível 1
 
Mensagens: 18
Data de registro: 10 Nov 2011 03:29
Cidade/Estado: Manaus/AM
Curtiu: 0 vez
Mens.Curtidas: 1 vez

NFS-e Erro: "Falha ao Recepcionar Lote de RPS"

Mensagempor Pablo César » 22 Mar 2012 21:59

Apenas uma dica... qual é o caracter que deve ser no final de arquivo ?
Um clip-abraço !

Pablo César Arrascaeta
Compartilhe suas dúvidas e soluções com todos os colegas aqui do fórum.
Evite enviar as dúvidas técnicas por MPs ou eMails, assim todos iremos beneficiar-nos.
Avatar de usuário

Pablo César
Usuário Nível 7

Usuário Nível 7
 
Mensagens: 5539
Data de registro: 31 Mai 2006 10:22
Cidade/Estado: Curitiba - Paraná
Curtiu: 142 vezes
Mens.Curtidas: 149 vezes

NFS-e Erro: "Falha ao Recepcionar Lote de RPS"

Mensagempor Tadeu » 23 Mar 2012 00:25

Bem, no manual não é mencionando especificamente nenhum caracter relativo ao final do arquivo. Existem alguns detalhes com relação ao preenchimento dos campos no sentido de evitar a utilização de caracteres que podem gerar algum erro, tipo :

** Não incluir zeros não significativos para campos numericos
** Não incluir espaços no inicio ou final de cada campo numerico e alfanumerico
** Não incluir comentarios no XML
** Não incluir anotação e documentação no XML
** Não incluir caracteres de formatação no XML ( line-feed., Return, Tab e caracteres de espaço entre as TAGS )

Então temos esses pontos acima que devem ser evitados, basicamente para ajudar a mantar o tamanho do arquivo o menor possível.

Como, eu consigo hoje gerar e validar a maioria dos arquivos gerados, acredito que não estaria relacionando aos pontos acimaç esse problema...

O que você acha ? Tem alguma suspeita ?

Abraços,

Tadeu
Tadeu
Usuário Nível 1

Usuário Nível 1
 
Mensagens: 18
Data de registro: 10 Nov 2011 03:29
Cidade/Estado: Manaus/AM
Curtiu: 0 vez
Mens.Curtidas: 1 vez

NFS-e Erro: "Falha ao Recepcionar Lote de RPS"

Mensagempor Pablo César » 23 Mar 2012 08:25

Sim eu compararia o arquivo que passou com o reprovado. Visualizaria ambos arquivos com um editor hexadecimal/decimal que possibilita mostrar todos os caracteres e olharia especificamente no final do arquivo.
Um clip-abraço !

Pablo César Arrascaeta
Compartilhe suas dúvidas e soluções com todos os colegas aqui do fórum.
Evite enviar as dúvidas técnicas por MPs ou eMails, assim todos iremos beneficiar-nos.
Avatar de usuário

Pablo César
Usuário Nível 7

Usuário Nível 7
 
Mensagens: 5539
Data de registro: 31 Mai 2006 10:22
Cidade/Estado: Curitiba - Paraná
Curtiu: 142 vezes
Mens.Curtidas: 149 vezes

NFS-e Erro: "Falha ao Recepcionar Lote de RPS"

Mensagempor JoséQuintas » 23 Mar 2012 11:07

a suspeita pode ser o CHR(26), que o DOS acrescenta ao fim do arquivo.
Abra no bloco de notas verifique o último caractere.
José M. C. Quintas
Harbour 3.4, mingw, gtwvg, multithread, dbfcdx, ADO+MySql, hbnetio, PNotepad
"The world is full of kings and queens, who blind our eyes and steal our dreams Its Heaven and Hell"
Avatar de usuário

JoséQuintas
Colaborador

Colaborador
 
Mensagens: 9419
Data de registro: 26 Fev 2007 11:59
Cidade/Estado: São Paulo-SP
Curtiu: 6 vezes
Mens.Curtidas: 548 vezes

NFS-e Erro: "Falha ao Recepcionar Lote de RPS"

Mensagempor Tadeu » 24 Mar 2012 12:21

Olá Pessoal, bom dia

A suspeita de vocês estava correta, fiz algumas verificações e alterei o código e agora o problema foi resolvido.... Valeu pelas dicas..!!!!

Um grande abraço...

Tadeu
Tadeu
Usuário Nível 1

Usuário Nível 1
 
Mensagens: 18
Data de registro: 10 Nov 2011 03:29
Cidade/Estado: Manaus/AM
Curtiu: 0 vez
Mens.Curtidas: 1 vez

NFS-e Erro: "Falha ao Recepcionar Lote de RPS"

Mensagempor Nascimento » 01 Dez 2017 21:48

amigo vc poderia postar um exemplo do codigo?
A arte de programar é simplismente fazer seus penssamentos serem interpletados por uma maquina :) clipper 5.3 /harbour 3.2
skype jnf-games
Avatar de usuário

Nascimento
Usuário Nível 3

Usuário Nível 3
 
Mensagens: 391
Data de registro: 19 Jul 2008 12:11
Cidade/Estado: OLINDA
Curtiu: 45 vezes
Mens.Curtidas: 32 vezes




Retornar para CA-Clipper

Quem está online

Usuários vendo este fórum: Bing [Bot] e 3 visitantes


Faça uma doação para o forum
v
Olá visitante, seja bem-vindo ao Fórum Clipper On Line!
Efetue o seu login ou faça o seu Registro